:

The Specified Management Service is Unreachable

Background Information

If you have not done it before and are unfamiliar with the  Oracle Enterprise Manager set-up and configuration, it can be quite a challenge  to install and configure correctly – that’s my opinion anyway.

It’s not just a case of installing the software and away you  go. You have to know where your servers are going to be from a network  perspective, i.e. what VLANs they are going to be in. Also, you need to get  specific ports open between the OMS and DB servers, all of which is difficult  to explain to the network team…

The Problem…

However, this article is relates to an error that I occurred  while installing the Enterprise Manager (EM) agent on a Windows server. I was  installing the software and all was going well. I got to the screen in the GUI  entitled:

“Specify Oracle Management Service Location”

Now, I knew that my colleague had set-up the OMS to listen  on port 1159 which meant that it was secured by a password. At this screen you  have to put in the hostname of the server where the OMS is and the port on  which you would like it to contact it. The default port is 4889, which is the  unsecure port.

The Oracle docs say that you must connect via the unsecure port  first in order to then secure it.

The error….

So I clicked next after typing in the hostname correctly,  and I got the following error:

“The specified management service on host omsserver.dev.int.com  at port 4889 is unreachable. Check the connection details for the Management  Service to ensure that you entered the value for the host name correctly.”

I went back, checked it and all was fine. I tried using the  IP address instead, but to no avail. I also tried the secure port, 1159,  without any luck.

Anyway, I discovered that you should just continue at this  point and secure the agent afterwards. So I did that and get the following  error message when attempting to secure the agent with the following command  from the <agent_home>\bin directory:

emctl secure agent -reg_passwd <password>

The above command produced the errors below:

****************
Another exception has been detected while we were handling  last error.
Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC                =  0x0000000010020070
SIGNAL            =  -1073741795
FUNCTION NAME     =  (N/A)
OFFSET            =  0xFFFFFFFF
LIBRARY NAME      =  (N/A)
Please check ERROR REPORT FILE for further information, if  there is any.
Good bye.
Oracle Enterprise Manager 10g Release 10.2.0.2.0.
Copyright (c) 1996, 2006 Oracle Corporation.  All rights reserved.

Agent is already stopped…    Done.
Securing agent…    Started.
Requesting an HTTPS Upload URL from the OMS…
****************
Another exception has been detected while we were handling  last error.Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC                =  0x0000000010020070
SIGNAL            =  -1073741795
FUNCTION NAME     =  (N/A)
OFFSET            =  0xFFFFFFFF
LIBRARY NAME      =  (N/A)
Please check ERROR REPORT FILE for further information, if  there is any.
Good bye.    Done.

Requesting an Oracle Wallet and Agent Key from the OMS…
****************
Another exception has been detected while we were handling  last error.
Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC                =  0x0000000010020070
SIGNAL            =  -1073741795
FUNCTION NAME     =  (N/A)
OFFSET            =  0xFFFFFFFF
LIBRARY NAME      =  (N/A)
Please check ERROR REPORT FILE for further information, if  there is any.
Good bye.    Failed.
Failed to contact the OMS at the HTTP URL set in  D:\Oracle\product\10.2.0\agent10g/sysman/config/emd.properties.
The Agent has not been secured.

The solution…

After some research and struggling with different settings  and configuration files, I managed to workout that there were some settings  that needed to be changed.

1) Edit this file:  D:\Oracle\product\10.2.0\agent10g/sysman/config/emd.properties. And put the  correct REPOSITORY_URL into it.

Original URL: REPOSITORY_URL=http://omsserver.dev.int.com:4889/em/upload/

New URL: REPOSITORY_URL=https://omsserver.dev.int.com:1159/em/upload/

Change the following URL from http and 4889 to https and  1159

2) emdWalletSrcUrl=https://omsserver.dev.int.com:1159/em/wallets/emd

If you are having issues with the agent, have a read of my other article on why the Oracle 10g agent won’t start.

Like it, share it...

Category: Enterprise Manager


Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *